Is SQL Server [Insert Version] supported with SharePoint?

Following up on my SharePoint Windows Matrix, here’s the same thing only with supported SQL Server versions.

2013 2010 2007 2003 2001
SQL Server 2012 All editions
64-bit
All editions
Requires SharePoint SP1
64-bit
     
SQL Server 2008 R2 SQL Server SP1
All editions
64-bit
All editions
64-bit
All editions
Requires SharePoint SP2
32-bit, 64-bit
   
SQL Server 2008   SQL Server SP1 + CU2 or CU5
CU3 or CU4 not recommended
All editions
64-bit
All editions
Requires SharePoint SP1
32-bit, 64-bit
   
SQL Server 2005   SQL Server SP3
All editions
64-bit
SQL Server SP1
All editions
32-bit, 64-bit
SQL Server SP4
Standard 32-bit, 64-bit
Enterprise 32-bit, 64-bit
Workgroup 32-bit, 64-bit
 
SQL Server 2000     SQL Server SP4
All editions
32-bit, 64-bit
Standard 32-bit, 64-bit
Enterprise 32-bit, 64-bit
Workgroup 32-bit, 64-bit
MSDE 32-bit, 64-bit
All editions
SQL Server 7.0         All editions

Notes

  1. An empty cell mean this SQL Server/SharePoint combination is not supported.
  2. This table reflects all SharePoint editions, i.e. WSS/Foundation and Server Standard/Enterprise/Internet Sites. In other words within a SharePoint version, the SQL Server requirements are the same.
  3. I’ve indicated if a minimum SQL Server or SharePoint Service Pack is required otherwise assume RTM and later.
  4. The documentation isn’t always complete. When specific editions are not provided, I’ve assumed all mainstream editions (e.g. Standard, Enterprise, Datacenter, Web, Workgroup, Express) are supported and used the phrase All editions.
  5. Why have I listed unsupported versions of SharePoint? One day you’ll encounter one of these ancient farms in need of some help and the answer will be obvious.

References

Share